$re = '/[a-zA-Z]+://[a-zA-Z]+\.[a-zA-Z]+/[a-zA-Z]+([+-]?(?=\.\d|\d)(?:\d+)?(?:\.?\d*))(?:[eE]([+-]?\d+))?_[0-9]+/m';
$str = 'https://vk.com/wall-170006123_92120';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;