use strict;
my $str = 'https://vk.com/wall-170006123_92120';
my $regex = qr/[a-zA-Z]+://[a-zA-Z]+\.[a-zA-Z]+/[a-zA-Z]+([+-]?(?=\.\d|\d)(?:\d+)?(?:\.?\d*))(?:[eE]([+-]?\d+))?_[0-9]+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";