const regex = new RegExp('[a-zA-Z]+://[a-zA-Z]+\\.[a-zA-Z]+/[a-zA-Z]+([+-]?(?=\\.\\d|\\d)(?:\\d+)?(?:\\.?\\d*))(?:[eE]([+-]?\\d+))?_[0-9]+', 'gm')
const str = `https://vk.com/wall-170006123_92120`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);