re = /[a-zA-Z]+:\/\/[a-zA-Z]+\.[a-zA-Z]+\/[a-zA-Z]+([+-]?(?=\.\d|\d)(?:\d+)?(?:\.?\d*))(?:[eE]([+-]?\d+))?_[0-9]+/m
str = 'https://vk.com/wall-170006123_92120'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result