use strict;
my $str = 'Aujourd\'hui séparer l\'élément en deux';
my $regex = qr/(?: |(?<!\w{2})')/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";