package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^assertEquals\(\s*(?<one>[^,]+)\s*,\s*(?<two>[^,]+)\s*,\s*(?<three>[^,;]+)\s*\);$`)
var str = `assertEquals("Size : Actual not as expected ", 3, existingEntity.getProperties().size());
assertEquals("Size : Actual not as expected ", 2, properties.size());
assertEquals("Verify CreatedBy", "SYSTEM", createdBy);
assertEquals("Verify ModifyBy", "JSS", existingUser.getModifiedBy());
existingUser.setFirstName("changed user name");
existingUser.setEmail("changed_user@domain.com");
existingUser.setTrustGroupId("TRG02");
existingUser.setUuid("UUID200");
// Query - Save (update)
// need to flush as within a non-committed transaction at this stage
this.userRepository.saveAndFlush(existingUser);`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}