# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^assertEquals\(\s*(?<one>[^,]+)\s*,\s*(?<two>[^,]+)\s*,\s*(?<three>[^,;]+)\s*\);$"
test_str = ("assertEquals(\"Size : Actual not as expected \", 3, existingEntity.getProperties().size());\n"
"assertEquals(\"Size : Actual not as expected \", 2, properties.size());\n"
"assertEquals(\"Verify CreatedBy\", \"SYSTEM\", createdBy);\n"
"assertEquals(\"Verify ModifyBy\", \"JSS\", existingUser.getModifiedBy());\n"
" existingUser.setFirstName(\"changed user name\");\n"
" existingUser.setEmail(\"changed_user@domain.com\");\n"
" existingUser.setTrustGroupId(\"TRG02\");\n"
" existingUser.setUuid(\"UUID200\");\n\n"
" // Query - Save (update)\n"
" // need to flush as within a non-committed transaction at this stage\n"
" this.userRepository.saveAndFlush(existingUser);")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.