const regex = /^assertEquals\(\s*(?<one>[^,]+)\s*,\s*(?<two>[^,]+)\s*,\s*(?<three>[^,;]+)\s*\);$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^assertEquals\\(\\s*(?<one>[^,]+)\\s*,\\s*(?<two>[^,]+)\\s*,\\s*(?<three>[^,;]+)\\s*\\);$', 'mg')
const str = `assertEquals("Size : Actual not as expected ", 3, existingEntity.getProperties().size());
assertEquals("Size : Actual not as expected ", 2, properties.size());
assertEquals("Verify CreatedBy", "SYSTEM", createdBy);
assertEquals("Verify ModifyBy", "JSS", existingUser.getModifiedBy());
existingUser.setFirstName("changed user name");
existingUser.setEmail("changed_user@domain.com");
existingUser.setTrustGroupId("TRG02");
existingUser.setUuid("UUID200");
// Query - Save (update)
// need to flush as within a non-committed transaction at this stage
this.userRepository.saveAndFlush(existingUser);`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}