use strict;
my $str = 'assertEquals("Size : Actual not as expected ", 3, existingEntity.getProperties().size());
assertEquals("Size : Actual not as expected ", 2, properties.size());
assertEquals("Verify CreatedBy", "SYSTEM", createdBy);
assertEquals("Verify ModifyBy", "JSS", existingUser.getModifiedBy());
existingUser.setFirstName("changed user name");
existingUser.setEmail("changed_user@domain.com");
existingUser.setTrustGroupId("TRG02");
existingUser.setUuid("UUID200");
// Query - Save (update)
// need to flush as within a non-committed transaction at this stage
this.userRepository.saveAndFlush(existingUser);';
my $regex = qr/^assertEquals\(\s*(?<one>[^,]+)\s*,\s*(?<two>[^,]+)\s*,\s*(?<three>[^,;]+)\s*\);$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}