import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^assertEquals\\(\\s*(?<one>[^,]+)\\s*,\\s*(?<two>[^,]+)\\s*,\\s*(?<three>[^,;]+)\\s*\\);$";
final String string = "assertEquals(\"Size : Actual not as expected \", 3, existingEntity.getProperties().size());\n"
+ "assertEquals(\"Size : Actual not as expected \", 2, properties.size());\n"
+ "assertEquals(\"Verify CreatedBy\", \"SYSTEM\", createdBy);\n"
+ "assertEquals(\"Verify ModifyBy\", \"JSS\", existingUser.getModifiedBy());\n"
+ " existingUser.setFirstName(\"changed user name\");\n"
+ " existingUser.setEmail(\"changed_user@domain.com\");\n"
+ " existingUser.setTrustGroupId(\"TRG02\");\n"
+ " existingUser.setUuid(\"UUID200\");\n\n"
+ " // Query - Save (update)\n"
+ " // need to flush as within a non-committed transaction at this stage\n"
+ " this.userRepository.saveAndFlush(existingUser);";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}