#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)-.*$"
Local $sString = "Knight Frank - Mayfair branch" & @CRLF & _
"Savills - Knightsbridge branch" & @CRLF & _
"Sotheby's" & @CRLF & _
"Hamptons International"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)