using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"-.*$";
string substitution = @"";
string input = @"Knight Frank - Mayfair branch
Savills - Knightsbridge branch
Sotheby's
Hamptons International";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}