use strict;
my $str = 'Knight Frank - Mayfair branch
Savills - Knightsbridge branch
Sotheby\'s
Hamptons International';
my $regex = qr/-.*$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";