package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)-.*$`)
var str = `Knight Frank - Mayfair branch
Savills - Knightsbridge branch
Sotheby's
Hamptons International`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}