package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\p{P}\s\w]{40,}`)
var str = `Wow cool song!Wow cool song!Wow cool song!Wow cool song! 🕺🏻
Wow cool song! 🕺🏻Wow cool song! 🕺🏻Wow cool song! 🕺🏻
漢語 漢語漢語漢語漢語漢語 漢語漢語漢語漢語漢語漢語漢語漢語漢語漢語漢語漢語漢語 رَرَرَرَرَبِرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةيَّة, al-ʻarabiy🕺🏻 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}