// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?um)[\p{P}\s\w]{40,}").unwrap();
let string = "Wow cool song!Wow cool song!Wow cool song!Wow cool song! 🕺🏻
Wow cool song! 🕺🏻Wow cool song! 🕺🏻Wow cool song! 🕺🏻
漢語 漢語漢語漢語漢語漢語 漢語漢語漢語漢語漢語漢語漢語漢語漢語漢語漢語漢語漢語 رَرَرَرَرَبِرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةيَّة, al-ʻarabiy🕺🏻 ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}