const regex = /[\p{P}\s\w]{40,}/ugm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\p{P}\\s\\w]{40,}', 'ugm')
const str = `Wow cool song!Wow cool song!Wow cool song!Wow cool song! 🕺🏻
Wow cool song! 🕺🏻Wow cool song! 🕺🏻Wow cool song! 🕺🏻
漢語 漢語漢語漢語漢語漢語 漢語漢語漢語漢語漢語漢語漢語漢語漢語漢語漢語漢語漢語 رَرَرَرَرَبِرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةيَّة, al-ʻarabiy🕺🏻 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}