re = /[\p{P}\s\w]{40,}/m
str = 'Wow cool song!Wow cool song!Wow cool song!Wow cool song! 🕺🏻
Wow cool song! 🕺🏻Wow cool song! 🕺🏻Wow cool song! 🕺🏻
漢語 漢語漢語漢語漢語漢語 漢語漢語漢語漢語漢語漢語漢語漢語漢語漢語漢語漢語漢語 رَرَرَرَرَبِرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةيَّة, al-ʻarabiy🕺🏻 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end