import re
regex = re.compile(r"[\p{P}\s\w]{40,}", flags=re.UNICODE | re.MULTILINE)
test_str = ("Wow cool song!Wow cool song!Wow cool song!Wow cool song! 🕺🏻 \n"
"Wow cool song! 🕺🏻Wow cool song! 🕺🏻Wow cool song! 🕺🏻\n"
"漢語 漢語漢語漢語漢語漢語 漢語漢語漢語漢語漢語漢語漢語漢語漢語漢語漢語漢語漢語 رَرَرَرَرَبِرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةرَبِيَّةيَّة, al-ʻarabiy🕺🏻 ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")