#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"description"\s*:\s*"([^"\\]*(?:\\.[^"\\]*)*)""
Local $sString = "{ "description": "Do you like donuts? If you're also a donuts lover, come on and enjoy it!"}, { "description": "JSON can have \"escaped quotes like this\", just to make things harder" } "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")