$re = '/"description"\s*:\s*"([^"\\\\]*(?:\\\\.[^"\\\\]*)*)"/m';
$str = '{ "description": "Do you like donuts? If you\'re also a donuts lover, come on and enjoy it!"}, { "description": "JSON can have \\"escaped quotes like this\\", just to make things harder" } ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);