package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"description"\s*:\s*"([^"\\]*(?:\\.[^"\\]*)*)"`)
var str = `{ "description": "Do you like donuts? If you're also a donuts lover, come on and enjoy it!"}, { "description": "JSON can have \"escaped quotes like this\", just to make things harder" } `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}