use strict;
my $str = '{ "description": "Do you like donuts? If you\'re also a donuts lover, come on and enjoy it!"}, { "description": "JSON can have \\"escaped quotes like this\\", just to make things harder" } ';
my $regex = qr/"description"\s*:\s*"([^"\\]*(?:\\.[^"\\]*)*)"/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}