// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"description"\s*:\s*"([^"\\]*(?:\\.[^"\\]*)*)""#).unwrap();
let string = "{ \"description\": \"Do you like donuts? If you're also a donuts lover, come on and enjoy it!\"}, { \"description\": \"JSON can have \\\"escaped quotes like this\\\", just to make things harder\" } ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}