using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![\""=\w])(?:[^\W_]+)(?![\""=\w])";
string input = @" a01a b02 c03 e dfdfd abcdef=2 b=3 e=4 c=""a b"" aaa=2f f=""asdf 12af""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}