const regex = new RegExp('(?<![\\"=\\w])(?:[^\\W_]+)(?![\\"=\\w])', 'g')
const str = ` a01a b02 c03 e dfdfd abcdef=2 b=3 e=4 c="a b" aaa=2f f="asdf 12af"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}