re = /(?<![\"=\w])(?:[^\W_]+)(?![\"=\w])/
str = ' a01a b02 c03 e dfdfd abcdef=2 b=3 e=4 c="a b" aaa=2f f="asdf 12af"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end