$re = '/(?<![\"=\w])(?:[^\W_]+)(?![\"=\w])/';
$str = ' a01a b02 c03 e dfdfd abcdef=2 b=3 e=4 c="a b" aaa=2f f="asdf 12af"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);