# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*?test=([0-9a-zA-Z]+).*/\1/gm;t' <<< "test=1233]
test=1233]323]
test=1233323abc"