using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*?test=([0-9a-zA-Z]+).*";
string substitution = @"\1";
string input = @"test=1233]
test=1233]323]
test=1233323abc";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}