$re = '/.*?test=([0-9a-zA-Z]+).*/m';
$str = 'test=1233]
test=1233]323]
test=1233323abc';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;