use strict;
my $str = 'test=1233]
test=1233]323]
test=1233323abc';
my $regex = qr/.*?test=([0-9a-zA-Z]+).*/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";