#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m).*?test=([0-9a-zA-Z]+).*"
Local $sString = "test=1233]" & @CRLF & _
"test=1233]323]" & @CRLF & _
"test=1233323abc"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)