package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<Workorder>\d{4}),(?<ExternalUnit>\d{7}),(?<Pieces>\d),(?<SubItem>\d+$)`)
var str = `6432,6432305,1,6432305038
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}