$re = '/(?<Workorder>\d{4}),(?<ExternalUnit>\d{7}),(?<Pieces>\d),(?<SubItem>\d+$)/';
$str = '6432,6432305,1,6432305038
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);