re = /(?<Workorder>\d{4}),(?<ExternalUnit>\d{7}),(?<Pieces>\d),(?<SubItem>\d+$)/
str = '6432,6432305,1,6432305038
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end