# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(?:APPLES|BANANAS|PEARS)\b(?:\s*(?:,\s*)?(?:(?:or|and)\s+)?(?:APPLES|BANANAS|PEARS))*\b/[\g<0>]/gmi;t' <<< "apples, pears, bananas are fruit
pears, apples, and bananas are in the fruit basket
you can use bananas, pears, and apples in a fruit salad
he also likes pears, bananas, and apples for a snack
she likes cheese for a snack but also apples or pears"