package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\b(?:APPLES|BANANAS|PEARS)\b(?:\s*(?:,\s*)?(?:(?:or|and)\s+)?(?:APPLES|BANANAS|PEARS))*\b`)
var str = `apples, pears, bananas are fruit
pears, apples, and bananas are in the fruit basket
you can use bananas, pears, and apples in a fruit salad
he also likes pears, bananas, and apples for a snack
she likes cheese for a snack but also apples or pears`
var substitution = "[\g<0>]"
fmt.Println(re.ReplaceAllString(str, substitution))
}