// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)\b(?:APPLES|BANANAS|PEARS)\b(?:\s*(?:,\s*)?(?:(?:or|and)\s+)?(?:APPLES|BANANAS|PEARS))*\b").unwrap();
let string = "apples, pears, bananas are fruit
pears, apples, and bananas are in the fruit basket
you can use bananas, pears, and apples in a fruit salad
he also likes pears, bananas, and apples for a snack
she likes cheese for a snack but also apples or pears";
let substitution = "[\\g<0>]";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}