import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:APPLES|BANANAS|PEARS)\\b(?:\\s*(?:,\\s*)?(?:(?:or|and)\\s+)?(?:APPLES|BANANAS|PEARS))*\\b";
final String string = "apples, pears, bananas are fruit\n"
+ "pears, apples, and bananas are in the fruit basket\n"
+ "you can use bananas, pears, and apples in a fruit salad\n"
+ "he also likes pears, bananas, and apples for a snack\n"
+ "she likes cheese for a snack but also apples or pears";
final String subst = "[\\g<0>]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}