# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(?:APPLES|BANANAS|PEARS)\b(?:\s*(?:,\s*)?(?:(?:or|and)\s+)?(?:APPLES|BANANAS|PEARS))*\b"
test_str = ("apples, pears, bananas are fruit\n"
"pears, apples, and bananas are in the fruit basket\n"
"you can use bananas, pears, and apples in a fruit salad\n"
"he also likes pears, bananas, and apples for a snack\n"
"she likes cheese for a snack but also apples or pears")
subst = "[\\g<0>]"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.