package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[0-9]{4}-(0[1-9]|1[0-2])-(0[1-9]|[1-2][1-9]|3[0-1])\s(0[0-9]|1[0-9]|2[0-3]):([0-5][0-9]):([0-5][0-9])`)
var str = `
2018-12-06 17:50:03
2019-09-19 08:44:42
2019-08-12 21:16:56
2019-04-25 15:05:29
2018-01-04 20:01:04
2019-07-24 08:01:00
2019-06-24 21:51:26
2016-12-22 19:19:14
2016-12-30 19:19:14
2016-12-31 19:19:14
2016-12-31 19:59:59
2016-12-31 19:00:00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}