import re
regex = re.compile(r"[0-9]{4}-(0[1-9]|1[0-2])-(0[1-9]|[1-2][1-9]|3[0-1])\s(0[0-9]|1[0-9]|2[0-3]):([0-5][0-9]):([0-5][0-9])", flags=re.MULTILINE)
test_str = ("\n"
"2018-12-06 17:50:03\n"
"2019-09-19 08:44:42\n"
"2019-08-12 21:16:56\n"
"2019-04-25 15:05:29\n"
"2018-01-04 20:01:04\n"
"2019-07-24 08:01:00\n"
"2019-06-24 21:51:26\n"
"2016-12-22 19:19:14\n"
"2016-12-30 19:19:14\n"
"2016-12-31 19:19:14\n"
"2016-12-31 19:59:59\n"
"2016-12-31 19:00:00")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")