using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(\w+)(?:\s+[^]]*)?].*?\[/\1](*SKIP)(*F)|[a-zA-Z0-9_.-]*@\S+\.\w+";
string input = @"example@yahoo.com
]example@yahoo.com[
[mail]exmaple@yahoo.com[/mail]
$texts[] = ""example@yahoo.com"";
$texts[] = ""[mail]example@yahoo.com[/mail]"";
$texts[] = ""[other]example@yahoo.com[/other]"";";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}