import Foundation
let pattern = #"\[(\w+)(?:\s+[^]]*)?].*?\[/\1](*SKIP)(*F)|[a-zA-Z0-9_.-]*@\S+\.\w+"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
example@yahoo.com
]example@yahoo.com[
[mail]exmaple@yahoo.com[/mail]
$texts[] = "example@yahoo.com";
$texts[] = "[mail]example@yahoo.com[/mail]";
$texts[] = "[other]example@yahoo.com[/other]";
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)