re = /\[(\w+)(?:\s+[^]]*)?].*?\[\/\1](*SKIP)(*F)|[a-zA-Z0-9_.-]*@\S+\.\w+/m
str = 'example@yahoo.com
]example@yahoo.com[
[mail]exmaple@yahoo.com[/mail]
$texts[] = "example@yahoo.com";
$texts[] = "[mail]example@yahoo.com[/mail]";
$texts[] = "[other]example@yahoo.com[/other]";'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end