const regex = new RegExp('\\[(\\w+)(?:\\s+[^]]*)?].*?\\[/\\1](*SKIP)(*F)|[a-zA-Z0-9_.-]*@\\S+\\.\\w+', 'gms')
const str = `example@yahoo.com
]example@yahoo.com[
[mail]exmaple@yahoo.com[/mail]
\$texts[] = "example@yahoo.com";
\$texts[] = "[mail]example@yahoo.com[/mail]";
\$texts[] = "[other]example@yahoo.com[/other]";`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}