package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*?)(?:\s*((?:[a-zA-Z]+[0-9]|[0-9]+[a-zA-Z]).*))?$`)
var str = `WASHER tey DIN6340 10.5 C 35;
CABINET EL
CYLINDER SCREW
M12x N15`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}