import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*?)(?:\\s*((?:[a-zA-Z]+[0-9]|[0-9]+[a-zA-Z]).*))?$";
final String string = "WASHER tey DIN6340 10.5 C 35;\n"
+ "CABINET EL\n"
+ "CYLINDER SCREW\n"
+ "M12x N15";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}