re = /^(.*?)(?:\s*((?:[a-zA-Z]+[0-9]|[0-9]+[a-zA-Z]).*))?$/m
str = 'WASHER tey DIN6340 10.5 C 35;
CABINET EL
CYLINDER SCREW
M12x N15'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end